Should my Flex 4 AutoComplete to be renamed as InputAssist?

August 25th, 2010

I am currently in a process of updating the code for the component previously known as “Flex 4 AutoComplete component with text highlighting”.

This process get me a chance to think a little bit about component branding.

What I’ve recently had learned that AutoComplete is a very common name for the component with such a functionality.

I know, at least, 4 different Flash platform contenders, all of them use “AutoComplete” word in its name:

  1. com.adobe.flex.extras.controls.AutoComplete control written for Flex 2;
  2. Flextras commercial component AutoCompleteComboBox;
  3. Hillel Coren’s AutoComplete control;
  4. And the last, but not least, the Flex 4 AutoComplete component written by Tenger Ivan.

While “AutoComplete” is a very strong brand and it is well known to the end users, I’d like to bring into Flex components naming world more creativity.

What if I will rename AutoComplete control to InputAssist? You see, my component not only “auto-completes”, it is also providing an helping hand to faster select the value in need from the list of options.

So, in general, what do you think of InputAssist name?